Цикл 1С // Выдержка из Синтаксис-Помощника | {isaenkov.iamroot.ru —}!

Цикл 1С // Выдержка из Синтаксис-Помощника

Для Каждого (For each)
Синтаксис:
Для Каждого <Имя переменной 1> Из <Имя переменной 2> Цикл
// Операторы
[Прервать;]
// Операторы
[Продолжить;]
// Операторы
КонецЦикла;

Англоязычный синтаксис:
For Each <Имя переменной 1> In <Имя переменной 2> Do
// Операторы
[Break;]
// Операторы
[Continue;]
// Операторы
EndDo;
Параметры:
<Имя переменной 1>
Переменная, которой при каждом повторении цикла присваивается значение очередного элемента коллекции.
Из
Синтаксическая связка для параметра <Имя переменной 2>.
<Имя переменной 2>
Переменная или выражение, предоставляющее коллекцию. Элементы этой
коллекции будут присваиваться параметру <Имя переменной 1>.
Цикл
Операторы, следующие за ключевым словом Цикл выполняются, пока значение переменной <Имя переменной> меньше значения <Выражение 2>.
// Операторы
Исполняемый оператор или последовательность таких операторов.
Прервать
Позволяет прервать выполнение цикла в любой точке. После выполнение этого оператора управление передается оператору, следующему за ключевым словом КонецЦикла.
Продолжить
Немедленно передает управление в начало цикла, где производится вычисление и проверка условий выполнения цикла. Операторы, следующие в теле цикла за ним, на данной итерации обхода не выполняются.

Пример:

КонецЦикла
Ключевое слово, которое завершает структуру оператора цикла.
Описание:
Оператор цикла Для каждого предназначен для циклического обхода коллекций значений. При каждой итерации цикла возвращается новый элемент коллекции. Обход осуществляется до тех пор, пока не будут перебраны все элементы коллекции.


Оставить комментарий